Legislate is compatible with major web browsers such as Chrome, Edge, Firefox and Safari.

Legislate is supported by the following browsers:

  1. Mac — Safari — Most recent stable version

  2. Windows and Mac — Google Chrome — Most recent stable version

  3. Windows and Mac — Mozilla Firefox — Most recent stable version

  4. Windows 10 – MS EDGE — Most recent stable version

Icons of chrome, safari, edge and firefox

Legislate will display a banner if it is not supported on your browser.

For the best use of Legislate we suggest:

Google Chrome — Free to download
Mozilla Firefox — Free to download
Apple Safari — Free to download

Did this answer your question?